CVE-2026-123542: OpenIdentityPlatform OpenAM · Improperly Implemented Security Check for Standard
Affects OpenIdentityPlatform OpenAMSource CVE Database V5
Not known to be exploited · CVSS 7.6 High : upgrade to 16.1.4 soon.
Data as of 8 Nov 2026, 02:17 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.6 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 6.8 |
- Patch
- Available – fixed in 16.1.4
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade OpenIdentityPlatform OpenAM to 16.1.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenIdentityPlatformOpenAM | Affected
| Fixed in
|
MavenOpenAMpkg:maven/OpenAMOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade OpenAM to version 16.1.4 or later, where the PKCE enforcement in the OAuth 2.0 device authorization flow is properly implemented. No other mitigation is indicated by the vendor advisory.
Description
OpenAM versions prior to 16.1.4 do not enforce the PKCE security mechanism in the OAuth 2.0 device authorization flow. Specifically, the code verifier is never validated when exchanging device codes for tokens. This flaw allows attackers who obtain a valid device code from client logs or shared device storage to redeem it for access and ID tokens, enabling user impersonation.