Skip to main content
VulnerabilityPublished

CVE-2026-124494: JiHong88 suneditor · Cross-site Scripting

Affects JiHong88 suneditorSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 3.4.0 as a priority.

Data as of 8 Nov 2026, 13:35 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.09.3
Patch
Available – fixed in 3.4.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.

What to do

Upgrade JiHong88 suneditor to 3.4.0.

Affected software

ProductAffectedFixed in
JiHong88suneditorAffected
  • <3.4.0
Fixed in
  • 3.4.0
npmsuneditorpkg:npm/suneditorOther threatsAffected
  • <3.4.0
Fixed in
  • 3.4.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade SunEditor to version 3.4.0 or later, where the vulnerability has been fixed. No other mitigation is required as the fix corrects the sanitizer's URL decoding behavior.

Description

SunEditor versions before 3.4.0 have a stored cross-site scripting (XSS) vulnerability due to improper input neutralization in the html.clean() sanitizer's _normalizeURL() function. This function decodes named entities like &colon; to an empty string, allowing attackers to inject malicious href values such as javascript: that bypass safety checks but execute JavaScript in victims' browsers when clicked. The vulnerability is fixed in version 3.4.0.

References

Community reviews

Loading reviews…