CVE-2026-12530: AWS bedrock-agentcore · Argument Injection
Affects AWS bedrock-agentcoreSource CVE Database V5
Not known to be exploited · CVSS 8.4 High : upgrade to 1.6.1 soon.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.6.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade AWS bedrock-agentcore to 1.6.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AWSbedrock-agentcore | Affected
| Fixed in
|
PyPIbedrock-agentcorepkg:pypi/bedrock-agentcoreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available. Users should upgrade AWS Bedrock AgentCore Python SDK to version 1.6.1 or later to remediate this vulnerability. Since this is a cloud service component, AWS manages remediation for the cloud-hosted service, but customers using the SDK should update their local installations accordingly. Check the AWS security advisory at https://aws.amazon.com/security/security-bulletins/2026-044-aws/ for the latest guidance.
Description
CVE-2026-12530 is a high-severity vulnerability in AWS Bedrock AgentCore Python SDK versions from 1.1.3 up to but not including 1.6.1. It involves improper neutralization of argument delimiters in the install_packages() method, which could allow a remote authenticated user to execute arbitrary commands within the Code Interpreter sandbox by crafting malicious package name arguments. AWS has released version 1.6.1 to address this issue.