CVE-2026-12697: wpForo Forum (WordPress plugin) · Insecure Direct Object Reference
Affects wpForo Forum (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 3.1.2 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 31 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade wpForo Forum (WordPress plugin) to 3.1.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| wpForo Forum | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restricting subscriber-level permissions or disabling the affected AI chat message deletion functionality may reduce risk.
Description
CVE-2026-12697 is a medium severity vulnerability in the wpForo Forum WordPress plugin before version 3.1.2. It allows subscriber-level users to delete AI chat message histories of other users without proper authorization verification. This occurs because the plugin does not confirm that the AI chat conversation being deleted belongs to the requesting user.