Skip to main content
VulnerabilityPublished

CVE-2026-12901: GetPaid (WordPress plugin) · Insufficient Verification of Data Authenticity

Affects GetPaid (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 2.8.55 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.8.55
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade GetPaid (WordPress plugin) to 2.8.55.

Affected software

ProductAffectedFixed in
GetPaidAffected
  • <2.8.55
Fixed in
  • 2.8.55

AI-suggested

If you cannot patch yet, users should consider additional verification mechanisms for payment notifications or temporarily disable the affected functionality if feasible.

Description

A vulnerability in the GetPaid WordPress plugin before version 2.8.55 allows unauthenticated attackers to forge Worldpay payment notifications. This flaw results from insufficient verification of data authenticity, enabling attackers to mark pending invoices as paid without actual payment.

References

Community reviews

Loading reviews…