CVE-2026-14319: GiveWP (WordPress plugin) · Information Exposure
Affects GiveWP (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 4.16.3 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.16.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade GiveWP (WordPress plugin) to 4.16.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GiveWP | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict access to the affected REST API endpoint through configuration or access control mechanisms to prevent unauthenticated access.
Description
GiveWP WordPress plugin versions before 4.16.3 have an information exposure vulnerability due to improper access restrictions on a REST API endpoint. This flaw allows unauthenticated users to access recurring donation records, including anonymous donors' names and subscription details. The vulnerability is identified as CWE-200 and has a high severity rating with a CVSS score of 7.5.