Skip to main content
CVE-2026-119125VulnerabilityPublished

Parse Server before 8.6.107 and 9.0.0 before 9.10.5-alpha.8 returns the stored value of a field reverted by a

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-119125· Low 2.3

Not known to be exploited · CVSS 2.3 Low : upgrade to 9.10.5-alpha.8 when convenient.

Data as of 29 Oct 2026, 19:45 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.02.3
CNA (VulnCheck)CVSS 3.13.1
Patch
Available – fixed in 9.10.5-alpha.8, 8.6.107
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade parse-server to 9.10.5-alpha.8; parse-server to 8.6.107; parse-server to 9.10.5-alpha.8 or 8.6.107.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.10.5-alpha.8
Fixed in
  • 9.10.5-alpha.8
parse-communityparse-serverAffected
  • <8.6.107
Fixed in
  • 8.6.107
npmparse-serverpkg:npm/parse-serverOther threatsAffected
  • >=9.0.0 <9.10.5-alpha.8
  • <8.6.107
Fixed in
  • 9.10.5-alpha.8
  • 8.6.107

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict update permissions to trusted clients and review beforeSave triggers that revert fields. Consider disabling protectedFieldsTriggerExempt if feasible to reduce exposure.

Description

Parse Server versions before 8.6.107 and 9.0.0 before 9.10.5-alpha.8 have a vulnerability where the stored value of a field reverted by a beforeSave trigger is returned in object update responses. This occurs even if the client lacks read access to that object or field. An authenticated client who can update an object with such a beforeSave trigger can read protected values, including raw MFA authData when protectedFieldsTriggerExempt is enabled.

References

Community reviews

Loading reviews…