CVE-2026-14337: Pegasystems Pega Infinity · Cross-site Scripting
Affects Pegasystems Pega InfinitySource CVE Database V5
Not known to be exploited · CVSS 4.6 Medium : upgrade to Infinity 25.1.4 when convenient.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in Infinity 25.1.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade Pegasystems Pega Infinity to Infinity 25.1.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PegasystemsPega Infinity | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict high privileged developer access to trusted personnel only and monitor for suspicious activity related to user interface components.
Description
Pega Infinity versions 23.1.0 through 25.1.3 contain a stored Cross-site Scripting (XSS) vulnerability in a user interface component. Exploitation requires a high privileged user with a developer role. The vulnerability allows improper neutralization of input during web page generation, potentially enabling script injection. The CVSS 4.0 base score is 4.6, indicating a medium severity level. There are no known exploits in the wild at this time.