Skip to main content
VulnerabilityPublished

CVE-2026-1728: WSO2 API Manager · Improper Privilege Management

Affects WSO2 API ManagerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical · fixed in 4.6.0.12 : patch WSO2 API Manager as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.6.0.12, 4.5.0.48, 4.4.0.63 +14
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
WSO2WSO2 API ManagerAffected
  • >=4.6.0 <4.6.0.12
Fixed in
  • 4.6.0.12
WSO2WSO2 API ManagerAffected
  • >=4.5.0 <4.5.0.48
Fixed in
  • 4.5.0.48
WSO2WSO2 API ManagerAffected
  • >=4.4.0 <4.4.0.63
Fixed in
  • 4.4.0.63
WSO2WSO2 API ManagerAffected
  • >=4.3.0 <4.3.0.99
Fixed in
  • 4.3.0.99
WSO2WSO2 API ManagerAffected
  • >=4.2.0 <4.2.0.188
Fixed in
  • 4.2.0.188
WSO2WSO2 API ManagerAffected
  • >=4.1.0 <4.1.0.248
Fixed in
  • 4.1.0.248

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict access to low-privileged user accounts and monitor for suspicious token usage where possible.

Description

CVE-2026-1728 is a critical vulnerability in WSO2 API Manager where tokens issued to low-privileged users are not sufficiently restricted. This flaw allows these tokens to access product-level Admin REST APIs, potentially enabling an attacker with a low-privileged account to escalate privileges to full administrative control. The vulnerability affects multiple specific versions of WSO2 API Manager.

References

Community reviews

Loading reviews…