Skip to main content
VulnerabilityPublished

CVE-2026-17544: PHP · Out-of-bounds Write

Affects PHPSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 8.5.9 or 8.4.24 soon.

Data as of 29 Oct 2026, 07:15 UTC

CVSS 4.0 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.5.9, 8.4.24
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U/AU:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade PHP and the Debian debian/php package to 8.5.9 or 8.4.24.

Affected software

ProductAffectedFixed in
PHP GroupPHPAffected
  • ≥ 8.5.*, < 8.5.9
Fixed in
  • 8.5.9
PHP GroupPHPAffected
  • ≥ 8.4.*, < 8.4.24
Fixed in
  • 8.4.24
Debiandebian/phppkg:deb/debian/phpOther threatsAffected
  • <8.4.24
  • <8.5.9
Fixed in
  • 8.4.24
  • 8.5.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should consider avoiding use of the bccomp() function with untrusted input or apply other protective measures such as input validation or runtime protections.

Description

CVE-2026-17544 is a high-severity vulnerability in the PHP programming language affecting versions 8.4.0 through 8.4.23 and 8.5.0 through 8.5.8. It involves an out-of-bounds write triggered by attacker-controlled inputs to the bccomp() function, which can cause stack and heap corruption. This vulnerability could potentially lead to serious memory corruption issues.

References

Community reviews

Loading reviews…