Skip to main content
VulnerabilityPublished

CVE-2026-18245: AWS Amplify Codegen UI · Code Injection

Affects AWS Amplify Codegen UISource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 9.0 Critical : upgrade to 2.20.6 as a priority.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
9.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.20.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade AWS Amplify Codegen UI to 2.20.6.

Affected software

ProductAffectedFixed in
AWSAmplify Codegen UIAffected
  • <2.20.6
Fixed in
  • 2.20.6

AI-suggested

AWS manages remediation for this cloud-hosted service and has released version 2.20.6 of @aws-amplify/codegen-ui-react to address this vulnerability. Users should upgrade to version 2.20.6 or later to remediate the issue. Check the AWS security bulletin at https://aws.amazon.com/security/security-bulletins/2026-066-aws/ for the latest guidance and confirmation of patch status.

Description

Improper control of code generation in Amazon @aws-amplify/codegen-ui-react before 2.20.6 might allow a remote authenticated user to execute arbitrary code in end-user browsers, developer machines, CI/CD environments, and server-side rendering contexts via crafted Studio component or theme schema values due to insufficient coverage and effectiveness of the input validation introduced for CVE-2025-4318. To remediate this issue, users should upgrade to version 2.20.6

References

Community reviews

Loading reviews…