CVE-2026-18457: RTI Connext Professional · Heap-based Buffer Overflow
Affects RTI Connext ProfessionalSource CVE Database V5
Not known to be exploited · CVSS 8.3 High : upgrade to 7.7.0.1 or 7.3.1.6 soon.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.7.0.1, 7.3.1.6
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade RTI Connext Professional to 7.7.0.1 or 7.3.1.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| RTIConnext Professional | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, consider restricting network access to affected components if feasible.
Description
CVE-2026-18457 is a heap-based buffer overflow vulnerability in RTI Connext Professional Core Libraries. It affects multiple versions ranging from 5.2.3 up to but not including 7.7.0.1. The vulnerability allows buffer overflow conditions that could be exploited to impact the integrity and availability of the affected software. The CVSS 4.0 base score is 8.3, indicating a high severity issue with network attack vector and no user interaction required.