Skip to main content
VulnerabilityPublished Updated

CVE-2026-2467: RTI Connext Professional · Heap-based Buffer Overflow

Affects RTI Connext ProfessionalSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.2 Critical : upgrade to 7.7.0 or 7.3.1.3 as a priority.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.7.0, 7.3.1.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:H/SC:N/SI:L/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade RTI Connext Professional to 7.7.0 or 7.3.1.3.

Affected software

ProductAffectedFixed in
RTIConnext ProfessionalAffected
  • 5.0.0 – 6.1.0
  • >=7.4.0 <7.7.0
  • >=7.0.0 <7.3.1.3
5 affected builds
Fixed in
  • 7.7.0
  • 7.3.1.3

AI-suggested

No vendor-provided mitigation or temporary fix is currently documented.

Description

Heap-based Buffer Overflow vulnerability in RTI Connext Professional (Core Libraries) allows Overflow Variables and Tags. This issue affects Connext Professional: from 7.4.0 before 7.7.0, from 7.0.0 before 7.3.1.3, from 6.1.0 before 6.1.*, from 6.0.0 before 6.0.*, from 5.3.0 before 5.3.*, from 5.2.0 before 5.2.*, from 5.0.0 before 5.1.*.

References

Community reviews

Loading reviews…