imgproxy ICO loader · V3: imgproxy has integer overflow
Affects github.com/imgproxy/imgproxy/v3Source GCVE Database
CVSS 9.8 Critical : upgrade to 4.0.16 as a priority.
Data as of 31 Oct 2026, 02:07 UTC
- Patch
- Available – fixed in 4.0.16
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HWhat to do
Upgrade github.com/imgproxy/imgproxy/v3 and github.com/imgproxy/imgproxy/v2 and github.com/imgproxy/imgproxy to 4.0.16.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Gogithub.com/imgproxy/imgproxy/v3 | Affected
| Fixed in
|
| Gogithub.com/imgproxy/imgproxy/v2 | Affected
| Fixed in
|
| Gogithub.com/imgproxy/imgproxy | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and the vulnerability is fixed in imgproxy version 4.0.16. Users should upgrade to version 4.0.16 or later to remediate this issue. No additional mitigation steps are required if the patch is applied.
Description
An integer overflow vulnerability exists in the ICO loader of imgproxy before version 4.0.16. The flaw occurs when a 32-bit attacker-controlled data size is added to a constant header length, causing an allocation size wraparound and resulting in a heap overflow. This can lead to denial of service or potentially remote code execution when processing a crafted ICO image.
References
- github.com/imgproxy/imgproxy/security/advisories/GHSA-hff9-5pqw-6w9f (opens in a new tab)
- github.com/imgproxy/imgproxy/commit/a821b6a4cb07a1bf2bb9077431d1c1e734d79917 (opens in a new tab)
- github.com/imgproxy/imgproxy (opens in a new tab)
- github.com/imgproxy/imgproxy/releases/tag/v4.0.16 (opens in a new tab)