Skip to main content
CVE-2026-110264VulnerabilityPublished Updated

GitLab CE/EE affecting all · Integer Overflow

Affects gitlabSource GCVE Database

0
Compare
Authoritative record:CVE-2026-110264· Critical 10.0

Not known to be exploited · CVSS 10.0 Critical · fixed in 19.5.1 : patch gitlab as a priority.

Data as of 31 Oct 2026, 01:38 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitLab)CVSS 3.110.0
Patch
Available – fixed in 19.5.1, 19.4.3, 19.3.6 +4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
RubyGemsgitlabpkg:gem/gitlabOther threatsAffected
  • >=7.0 <18.11.13
  • >=19.0 <19.0.10
  • >=19.1 <19.1.9
  • >=19.2 <19.2.9
  • >=19.3 <19.3.6
  • >=19.4 <19.4.3
  • >=19.5 <19.5.1
Fixed in
  • 18.11.13
  • 19.0.10
  • 19.1.9
  • 19.2.9
  • 19.3.6
  • 19.4.3
  • 19.5.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions are available: upgrade GitLab CE/EE to at least one of the following versions: 18.11.13, 19.0.10, 19.1.9, 19.2.9, 19.3.6, 19.4.3, or 19.5.1. No other mitigation or temporary workaround is indicated. Applying the official patches is the recommended remediation.

Description

A critical vulnerability (CVE-2026-110264) affects GitLab CE/EE versions from 7.0 up to but not including several fixed releases before 18.11.13, 19.0.10, 19.1.9, 19.2.9, 19.3.6, 19.4.3, and 19.5.1. This flaw allows an unauthenticated attacker to execute arbitrary code on the GitLab server by exploiting an integer overflow during the compilation of a specially crafted regular expression.

References

Community reviews

Loading reviews…