CVE-2025-55154: imagemagick · integer overflows in MNG magnification
Affects Magick.NET-Q8-x86Source GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 14.8.0 soon.
Data as of 31 Oct 2026, 01:24 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 8.8 |
|---|
- Patch
- Available – fixed in 14.8.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Magick.NET-Q8-x86 and Magick.NET-Q8-x64 and Magick.NET-Q8-arm64 and Magick.NET-Q8-OpenMP-x64 and Magick.NET-Q8-OpenMP-arm64 and Magick.NET-Q8-AnyCPU and Magick.NET-Q16-x86 and Magick.NET-Q16-x64 and Magick.NET-Q16-arm64 and Magick.NET-Q16-OpenMP-x64 and Magick.NET-Q16-OpenMP-arm64 and Magick.NET-Q16-HDRI-x86 and Magick.NET-Q16-HDRI-x64 and Magick.NET-Q16-HDRI-arm64 and Magick.NET-Q16-HDRI-OpenMP-x64 and Magick.NET-Q16-HDRI-OpenMP-arm64 and Magick.NET-Q16-HDRI-AnyCPU and Magick.NET-Q16-AnyCPU to 14.8.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| NuGetMagick.NET-Q8-x86 | Affected
| Fixed in
|
| NuGetMagick.NET-Q8-x64 | Affected
| Fixed in
|
| NuGetMagick.NET-Q8-arm64 | Affected
| Fixed in
|
| NuGetMagick.NET-Q8-OpenMP-x64 | Affected
| Fixed in
|
| NuGetMagick.NET-Q8-OpenMP-arm64 | Affected
| Fixed in
|
| NuGetMagick.NET-Q8-AnyCPU | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in ImageMagick version 14.8.0. Users should upgrade to version 14.8.0 or later to remediate this vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
CVE-2025-55154 is a high-severity vulnerability in ImageMagick's MNG image processing component. It involves integer overflow in magnified size calculations within the ReadOneMNGImage function, which can lead to memory corruption. This flaw affects versions prior to 14.8.0. A fix is available in version 14.8.0.
References
- github.com/ImageMagick/ImageMagick/security/advisories/GHSA-qp29-wxp5-wh82 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-55154 (opens in a new tab)
- github.com/ImageMagick/ImageMagick (opens in a new tab)
- github.com/dlemstra/Magick.NET/releases/tag/14.8.0 (opens in a new tab)
- issuetracker.google.com/savedsearches/7155917 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/09/msg00012.html (opens in a new tab)