Skip to main content
VulnerabilityPublished

CVE-2026-118775: Forge · ASN.1 OID first arc truncation in asn1.oidToDer

Affects node-forgeSource GCVE Database

0
Compare
Authoritative record:CVE-2026-118775· Low 3.7

Not known to be exploited · CVSS 3.7 Low : upgrade to 1.4.1 when convenient.

Data as of 31 Oct 2026, 01:55 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.13.7
Patch
Available – fixed in 1.4.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade node-forge to 1.4.1.

Affected software

ProductAffectedFixed in
npmnode-forgeAffected
  • <1.4.1
Fixed in
  • 1.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade node-forge to version 1.4.1 or later, where the vulnerability is fixed. In this version, asn1.oidToDer() throws an error for OIDs with out-of-range first arcs and correctly encodes and decodes the first subidentifier. If upgrading immediately is not possible, validate OID strings from untrusted input before passing them to node-forge, ensuring the first arc is 0, 1, or 2, and the second arc is at most 39 when the first arc is 0 or 1.

Description

The node-forge library's function asn1.oidToDer() improperly encoded Object Identifier (OID) strings with out-of-range first arcs, causing them to be encoded as different, trusted OIDs. This flaw was an incomplete fix of a previous vulnerability and affected versions prior to 1.4.1. The issue was fixed in version 1.4.1 by rejecting out-of-range first arcs and correctly encoding the first subidentifier. The vulnerability allows an attacker to cause applications that accept untrusted OID strings and encode them with node-forge to emit a different OID than intended, potentially bypassing string-based OID checks. There is no impact on confidentiality or availability, and DER parsing is unaffected.

References

Community reviews

Loading reviews…