CVE-2026-118779: Forge · Regular expression denial of service in PEM decoding (pem.decode)
Affects node-forgeSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 1.4.1 soon.
Data as of 31 Oct 2026, 01:55 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 1.4.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade node-forge to 1.4.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmnode-forge | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade node-forge to version 1.4.1 or later, where the vulnerability is fixed with a linear-time PEM parser. As a temporary workaround, reject untrusted PEM inputs larger than a few kilobytes before parsing, though this only limits the delay and does not fully mitigate the issue.
Description
A Regular Expression Denial of Service (ReDoS) vulnerability exists in node-forge's pem.decode() function prior to version 1.4.1. The vulnerability arises from inefficient regular expressions used to parse PEM-encoded data, causing the Node.js event loop to block for seconds to minutes when processing crafted inputs. This affects any application that parses untrusted PEM text using node-forge, such as services handling uploaded certificates or keys. The issue is fixed in node-forge version 1.4.1.
References
- github.com/digitalbazaar/forge/security/advisories/GHSA-7wch-p9px-956x (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-118779 (opens in a new tab)
- github.com/digitalbazaar/forge/commit/412345db583cd28a9d23636d0d93e9f751b935f3 (opens in a new tab)
- github.com/digitalbazaar/forge (opens in a new tab)
- github.com/digitalbazaar/forge/releases/tag/v1.4.1 (opens in a new tab)