Skip to main content
VulnerabilityPublished

ICO loader BMP header reconstruction · V3: imgproxy has out-of-bounds heap read/write

Affects github.com/imgproxy/imgproxy/v3Source GCVE Database

0

CVSS 7.5 High : upgrade to 4.0.17 soon.

Data as of 31 Oct 2026, 02:07 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.0.17
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

What to do

Upgrade github.com/imgproxy/imgproxy/v3 to 4.0.17.

Affected software

ProductAffectedFixed in
Gogithub.com/imgproxy/imgproxy/v3Affected
  • >=3.3.0 <4.0.17
Fixed in
  • 4.0.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in imgproxy version 4.0.17 that fixes this vulnerability. Users should upgrade to version 4.0.17 or later to remediate this issue. Until upgraded, avoid processing untrusted ICO images or disable ICO support if possible.

Description

A heap out-of-bounds write vulnerability exists in imgproxy's ICO loader affecting versions from 3.3.0 up to but not including 4.0.17. The flaw occurs during BMP header reconstruction when processing ICO images with a crafted small data buffer, causing heap corruption and a deterministic worker crash. This results in denial of service by terminating the worker handling the request.

References

Community reviews

Loading reviews…