Skip to main content
VulnerabilityPublished

ICO loader · V3: imgproxy has unbounded memory allocation

Affects github.com/imgproxy/imgproxy/v3Source GCVE Database

0

CVSS 7.5 High : upgrade to 4.0.16 soon.

Data as of 31 Oct 2026, 02:07 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.0.16
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

What to do

Upgrade github.com/imgproxy/imgproxy/v3 to 4.0.16.

Affected software

ProductAffectedFixed in
Gogithub.com/imgproxy/imgproxy/v3Affected
  • >=3.3.0 <4.0.16
Fixed in
  • 4.0.16

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch fixing this vulnerability is available in imgproxy version 4.0.16. Users should upgrade to version 4.0.16 or later to remediate this issue. Until upgraded, restricting or validating ICO image inputs may reduce exposure. No other vendor mitigation or workaround is documented.

Description

A vulnerability in imgproxy's ICO image loader allows unauthenticated attackers to trigger unbounded memory allocation by crafting a specially formed ICO file. The flaw exists because the ICO loader reads a data size field from the file without validation and uses it directly to allocate memory, potentially causing a ~4GB allocation from a small 23-byte file. This can lead to denial of service via memory exhaustion on affected imgproxy versions prior to 4.0.16.

References

Community reviews

Loading reviews…