Skip to main content
VulnerabilityPublished

CVE-2026-18460: RTI Connext Professional · Off-by-one Error

Affects RTI Connext ProfessionalSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 7.7.0.1 or 7.3.1.6 when convenient.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.7.0.1, 7.3.1.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade RTI Connext Professional to 7.7.0.1 or 7.3.1.6.

Affected software

ProductAffectedFixed in
RTIConnext ProfessionalAffected
  • >=7.4.0 <7.7.0.1
Fixed in
  • 7.7.0.1
RTIConnext ProfessionalAffected
  • >=7.0.0 <7.3.1.6
Fixed in
  • 7.3.1.6

Description

CVE-2026-18460 is an off-by-one error vulnerability in RTI Connext Professional Core Libraries that allows out-of-bounds write leading to buffer overflow. It affects versions from 7.0.0 up to but not including 7.3.1.6, and from 7.4.0 up to but not including 7.7.0.1. The vulnerability has a CVSS 4.0 base score of 6.9, indicating medium severity. No known exploits are reported in the wild.

References

Community reviews

Loading reviews…