Skip to main content
VulnerabilityPublished Updated

CVE-2026-2674: RTI Connext Professional · Out-of-bounds Write

Affects RTI Connext ProfessionalSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 7.7.0 or 7.3.1.3 when convenient.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.7.0, 7.3.1.3
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade RTI Connext Professional to 7.7.0 or 7.3.1.3.

Affected software

ProductAffectedFixed in
RTIConnext ProfessionalAffected
  • >=7.4.0 <7.7.0
  • >=7.0.0 <7.3.1.3
  • =6.1.0
Fixed in
  • 7.7.0
  • 7.3.1.3

AI-suggested

Restricting local access to trusted users may reduce risk given the local attack vector.

Description

Out-of-bounds Write vulnerability in RTI Connext Professional (Queueing Service,Core Libraries,Persistence Service) allows Overflow Buffers. This issue affects Connext Professional: from 7.4.0 before 7.7.0, from 7.0.0 before 7.3.1.3, from 6.1.0 before 6.1.*.

References

Community reviews

Loading reviews…