Skip to main content
CVE-2026-1927VulnerabilityPublished Updated

CVE-2026-1927: Greenshift (WordPress plugin) · Missing Authorization

Affects Greenshift (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 5.4 Medium · fixed in 12.6 : update Greenshift (WordPress plugin) when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 12.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
wpsoulGreenshift – animation and page builder blocksAffected
  • <=12.6
Fixed in–

AI-suggested

Users should verify with the plugin vendor for updates beyond version 12.6. Until a full fix is confirmed, restrict Subscriber-level access where possible and monitor for suspicious activity related to plugin settings. Avoid using versions up to 12.6 in sensitive environments.

Description

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the greenshift_app_pass_validation() function in all versions up to, and including, 12.6. This makes it possible for authenticated attackers, with Subscriber-level access and above, to retrieve global plugin settings including stored AI API keys and modify plugin settings, including the injection of arbitrary web scripts via the 'custom_css' value (stored XSS). NOTE: This vulnerability was partially patched in version 12.6.

References

Community reviews

Loading reviews…