Skip to main content
VulnerabilityPublished

CVE-2026-21425: Dell PowerScale OneFS · Incorrect Privilege Assignment

Affects Dell PowerScale OneFSSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.7 Medium : upgrade to 9.13.0.0 or later or 9.10.1.6 or later when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.7Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.08% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.13.0.0 or later, 9.10.1.6 or later, 9.10.1.6
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade PowerScale OneFS to 9.13.0.0 or later or 9.10.1.6 or later; dell/powerscale-onefs to 9.10.1.6.

Affected software

ProductAffectedFixed in
DellPowerScale OneFSAffected
  • ≥ prior to 9.10.1.6, < 9.10.1.6 or later
  • ≥ 9.11.0.0 through 9.12.0.1, < 9.13.0.0 or later
Fixed in
  • 9.13.0.0 or later
  • 9.10.1.6 or later
Delldell/powerscale-onefspkg:rpm/dell/powerscale-onefsOther threatsAffected
  • <9.10.1.6
  • >=9.11.0.0 <=9.12.0.1
Fixed in
  • 9.10.1.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Immediately restrict local access to systems running affected OneFS versions to trusted personnel only.
  2. Monitor and audit local user activities for suspicious privilege escalation attempts.
  3. Apply principle of least privilege to all user accounts and services on the affected systems.
  4. Disable or limit unnecessary user interaction mechanisms that could facilitate exploitation.
  5. Stay alert for official patches or updates from Dell and apply them promptly once available.
  6. Implement network segmentation to isolate storage systems from less trusted network zones.
  7. Use endpoint detection and response (EDR) tools to detect anomalous behavior indicative of privilege escalation.
  8. Conduct regular vulnerability assessments and penetration testing focused on privilege management controls.

Description

Dell PowerScale OneFS, versions prior to 9.10.1.6 and versions 9.11.0.0 through 9.12.0.1, contains an incorrect privilege assignment vulnerability. A low privileged attacker with local access could potentially exploit this vulnerability, leading to Elevation of privileges.

References

Community reviews

Loading reviews…