CVE-2026-21570: Atlassian Bamboo Data Center · Remote Code Execution
Affects Atlassian Bamboo Data CenterSource CVE Database V5
Not known to be exploited · CVSS 8.6 High.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AtlassianBamboo Data Center | Affected
| Fixed in– |
Mavencom.atlassian.bamboo/bamboo-datacenterpkg:maven/com.atlassian.bamboo/bamboo-datacenterOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Organizations should immediately assess their Bamboo Data Center deployments to identify affected versions. The primary mitigation is to upgrade Bamboo Data Center to the latest patched versions: 9.6.24 or higher for 9.6.x series, 10.2.16 or higher for 10.2.x series, and 12.1.3 or higher for 12.1.x series. If immediate upgrade is not feasible, restrict access to Bamboo servers by implementing network segmentation and strict access controls to limit authenticated user exposure. Enforce strong authentication mechanisms, including multi-factor authentication (MFA), to reduce the risk of credential compromise. Monitor Bamboo logs and network traffic for unusual activities indicative of exploitation attempts. Regularly audit user privileges to ensure least privilege principles are followed. Additionally, integrate Bamboo security into the overall software supply chain security strategy, including code signing and artifact verification, to detect potential tampering resulting from exploitation.
Description
This High severity RCE (Remote Code Execution) vulnerability was introduced in versions 9.6.0, 10.0.0, 10.1.0, 10.2.0, 11.0.0, 11.1.0, 12.0.0, and 12.1.0 of Bamboo Data Center. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 8.6, allows an authenticated attacker to execute malicious code on the remote system. Atlassian recommends that Bamboo Data Center customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Bamboo Data Center 9.6: Upgrade to a release greater than or equal to 9.6.24 Bamboo Data Center 10.2: Upgrade to a release greater than or equal to 10.2.16 Bamboo Data Center 12.1: Upgrade to a release greater than or equal to 12.1.3 See the release notes ([https://confluence.atlassian.com/bambooreleases/bamboo-release-notes-1189793869.html]). You can download the latest version of Bamboo Data Center from the download center ([https://www.atlassian.com/software/bamboo/download-archives]). This vulnerability was reported via our Atlassian (Internal) program.