Skip to main content
CVE-2026-22034VulnerabilityPublished

CVE-2026-22034: jvoisin snuffleupagus · Failing Open

Affects jvoisin snuffleupagusSource CVE Database V5

0

Not known to be exploited · CVSS 9.2 Critical : upgrade to 0.13.0 as a priority.

Data as of 26 Oct 2026, 06:15 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.13.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade snuffleupagus and jvoisin/snuffleupagus to 0.13.0.

Affected software

ProductAffectedFixed in
jvoisinsnuffleupagusAffected
  • <0.13.0
Fixed in
  • 0.13.0
GitHubjvoisin/snuffleupaguspkg:github/jvoisin/snuffleupagusOther threatsAffected
  • <0.13.0
Fixed in
  • 0.13.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediately upgrade Snuffleupagus to version 0.13.0 or later, which contains the fix for this vulnerability. 2. If upgrading is not immediately possible, disable the non-default upload validation feature or avoid using VLD-based validation scripts. 3. Ensure the Vulcan Logic Disassembler (VLD) PHP extension is installed and properly enabled for the CLI SAPI if upload validation is required. 4. Implement strict file upload controls at the application level, including whitelisting allowed file types and scanning uploads for malicious content. 5. Employ web application firewalls (WAFs) with rules to detect and block suspicious multipart POST requests containing PHP code. 6. Monitor web server and PHP logs for unusual file upload activity or execution of unexpected PHP scripts. 7. Conduct regular security audits and penetration testing focusing on file upload functionalities. 8. Educate developers and system administrators about secure PHP configuration and the risks of failing open in security modules. 9. Maintain up-to-date backups and incident response plans to quickly recover from potential compromises.

Description

Snuffleupagus is a module that raises the cost of attacks against website by killing bug classes and providing a virtual patching system. On deployments of Snuffleupagus prior to version 0.13.0 with the non-default upload validation feature enabled and configured to use one of the upstream validation scripts based on Vulcan Logic Disassembler (VLD) while the VLD extension is not available to the CLI SAPI, all files from multipart POST requests are evaluated as PHP code. The issue was fixed in version 0.13.0.

References

Community reviews

Loading reviews…