Skip to main content
VulnerabilityPublished

CVE-2026-22201: wpDiscuz (WordPress plugin) · Use of Less Trusted Source

Affects wpDiscuz (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 7.6.47 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.6.47
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade wpDiscuz (WordPress plugin) to 7.6.47.

Affected software

ProductAffectedFixed in
gVectorswpDiscuzAffected
  • <7.6.47
Fixed in
  • 7.6.47

AI-suggested

  1. Upgrade wpDiscuz to version 7.6.47 or later, where the vulnerability is fixed by properly validating IP addresses and not trusting untrusted HTTP headers.
  2. Implement server-side validation of client IP addresses by relying on trusted sources such as the direct connection IP or validated proxy headers configured at the web server or load balancer level.
  3. Configure web servers or reverse proxies to strip or override untrusted HTTP_CLIENT_IP and HTTP_X_FORWARDED_FOR headers from incoming requests to prevent spoofing.
  4. Employ additional security controls such as CAPTCHA, behavioral analysis, or user authentication to reduce reliance on IP-based rate limiting alone.
  5. Monitor logs for suspicious patterns of IP spoofing or repeated bypass attempts.
  6. Educate administrators to recognize the limitations of IP-based controls and adopt layered security approaches.
  7. Regularly audit and update WordPress plugins to ensure vulnerabilities are patched promptly.

Description

CVE-2026-22201 is a medium severity IP spoofing vulnerability in the wpDiscuz WordPress plugin before version 7.6.47. The vulnerability arises because the getIP() function trusts untrusted HTTP headers such as HTTP_CLIENT_IP and HTTP_X_FORWARDED_FOR, allowing attackers to spoof their IP address. This spoofing enables attackers to bypass IP-based rate limiting and ban enforcement mechanisms, potentially facilitating abuse or evasion of security controls. Exploitation requires no authentication or user interaction and can be performed remotely over the network. Although no known exploits are currently in the wild, the vulnerability poses a risk to websites using vulnerable versions of wpDiscuz, especially those relying on IP-based controls for security. Organizations should update wpDiscuz to version 7.6.47 or later and implement additional validation of client IP addresses to mitigate this risk.

References

Community reviews

Loading reviews…