Skip to main content
VulnerabilityPublished Updated

CVE-2026-22704: haxtheweb issues · Cross-site Scripting

Affects haxtheweb issuesSource CVE Database V5

0

Public exploit available (Exploit-DB) · CVSS 8.1 High : upgrade to 25.0.0 as a priority.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 25.0.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 10 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by GitHub, Inc.

    , 35 hours before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. In Threat Radar

    record ingested

    , 17 minutes after disclosure

  4. First Exploit-DB entry (opens in a new tab)

    HAX CMS 24.x - Stored Cross-Site Scripting (XSS)

    , 109 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade issues and haxtheweb/issues to 25.0.0.

Affected software

ProductAffectedFixed in
haxthewebissuesAffected
  • >=11.0.6 <25.0.0
Fixed in
  • 25.0.0
GitHubhaxtheweb/issuespkg:github/haxtheweb/issuesOther threatsAffected
  • <25.0.0 >=11.0.6
Fixed in
  • 25.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate this vulnerability, European organizations should immediately upgrade all instances of HAX CMS to version 25.0.0 or later, where the vulnerability has been patched. In parallel, implement strict input validation and output encoding on all user-supplied data to prevent injection of malicious scripts. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers. Conduct thorough security audits and penetration testing focused on XSS vectors within the CMS environment. Educate developers and administrators on secure coding practices, particularly regarding input sanitization and output encoding. Monitor logs and user activity for signs of exploitation attempts or unusual behavior. If upgrading is not immediately feasible, consider deploying Web Application Firewalls (WAFs) with custom rules to detect and block XSS payloads targeting HAX CMS endpoints. Finally, maintain an incident response plan to quickly address any detected compromise resulting from this vulnerability.

Description

HAX CMS helps manage microsite universe with PHP or NodeJs backends. In versions 11.0.6 to before 25.0.0, HAX CMS is vulnerable to stored XSS, which could lead to account takeover. This issue has been patched in version 25.0.0.

References

Community reviews

Loading reviews…