CVE-2026-22774: sveltejs devalue · Asymmetric Resource Consumption (Amplification)
Affects sveltejs devalueSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 5.6.2 soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.6.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 15 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade sveltejs devalue to 5.6.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| sveltejsdevalue | Affected
| Fixed in
|
npmdevaluepkg:npm/devalueOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official fix is available in sveltejs devalue version 5.6.2. Users should upgrade to version 5.6.2 or later to remediate this vulnerability. Since this is not a cloud service, remediation requires updating the affected library in the application. Patch status is confirmed by the vendor advisory. No additional mitigations are specified.
Description
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From 5.3.0 to 5.6.1, certain inputs can cause devalue.parse to consume excessive CPU time and/or memory, potentially leading to denial of service in systems that parse input from untrusted sources. This affects applications using devalue.parse on externally-supplied data. The root cause is the typed array hydration expecting an ArrayBuffer as input, but not checking the assumption before creating the typed array. This vulnerability is fixed in 5.6.2.
References
- github.com/sveltejs/devalue/security/advisories/GHSA-vw5p-8cq8-m7mv (opens in a new tab)
- github.com/sveltejs/devalue/commit/e46afa64dd2b25aa35fb905ba5d20cea63aabbf7 (opens in a new tab)
- github.com/sveltejs/devalue/releases/tag/v5.6.2 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-22774 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2430095 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-22774.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:2926 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:2144 (opens in a new tab)