Skip to main content
CVE-2026-22804VulnerabilityPublished

CVE-2026-22804: Termix · Improper Privilege Management

Affects TermixSource CVE Database V5

0

Not known to be exploited · CVSS 8.0 High : upgrade to 1.10.0 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
8.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.10.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Termix to 1.10.0.

Affected software

ProductAffectedFixed in
Termix-SSHTermixAffected
  • >=1.7.0 <1.10.0
Fixed in
  • 1.10.0

AI-suggested

The primary mitigation is to upgrade all Termix instances to version 1.10.0 or later, where the vulnerability has been fixed by proper SVG content sanitization. Until patching is possible, organizations should restrict or disable the file preview functionality within Termix, especially for SVG files, to prevent execution of malicious scripts. Implementing Web Application Firewall (WAF) rules to detect and block malicious SVG payloads can provide an additional layer of defense. Network segmentation and strict access controls should limit who can upload files to managed SSH servers to reduce the risk of planting malicious files. Monitoring and alerting on unusual file uploads or preview activity can help detect exploitation attempts. Educating users about the risk of previewing untrusted files and enforcing the principle of least privilege for Termix users will also reduce exposure. Finally, organizations should review and harden their SSH server security posture to prevent initial compromise, as the vulnerability requires prior access to the managed server.

Description

CVE-2026-22804 is a high-severity Stored Cross-Site Scripting (XSS) vulnerability affecting Termix versions 1.7.0 through 1.9.0. The flaw exists in the Termix File Manager component, where SVG file content is not properly sanitized before rendering. An attacker who has compromised a managed SSH server can plant a malicious SVG file that executes arbitrary JavaScript when previewed by a Termix user. This vulnerability can lead to full compromise of user sessions and potentially the application itself. It requires no privileges but does require user interaction to preview the malicious file. The issue is fixed in version 1.

References

Community reviews

Loading reviews…