Skip to main content
VulnerabilityPublished

CVE-2026-22870: DataDog guarddog · Data Amplification

Affects DataDog guarddogSource CVE Database V5

0

Not known to be exploited · CVSS 7.1 High : upgrade to 2.7.1 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.7.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade DataDog guarddog to 2.7.1.

Affected software

ProductAffectedFixed in
DataDogguarddogAffected
  • <2.7.1
Fixed in
  • 2.7.1
PyPIguarddogpkg:pypi/guarddogOther threatsAffected
  • <2.7.1
Fixed in
  • 2.7.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade GuardDog to version 2.7.1 or later to ensure the vulnerability is patched. In addition, implement the following measures: 1) Enforce strict resource quotas and disk usage limits on environments running GuardDog to contain potential zip bomb effects. 2) Use sandboxed or isolated environments for package extraction to prevent system-wide resource exhaustion. 3) Monitor disk usage and set alerts for unusual spikes during package scanning activities. 4) Integrate additional scanning tools that analyze package contents for suspicious compression ratios before extraction. 5) Educate developers and security teams about the risks of zip bombs and encourage cautious handling of untrusted packages. 6) Review and harden CI/CD pipeline configurations to gracefully handle failures caused by resource exhaustion. These targeted mitigations complement the patch and reduce the risk of denial of service from malicious compressed archives.

Description

CVE-2026-22870 is a high-severity vulnerability in DataDog's GuardDog CLI tool versions prior to 2.7.1. The flaw arises from improper handling of highly compressed ZIP archives during extraction, specifically a lack of validation on decompressed file sizes. This allows attackers to craft malicious PyPI packages containing zip bombs that expand to consume gigabytes of disk space from a few megabytes of compressed data, leading to denial of service (DoS). Exploitation requires no privileges but does require user interaction to extract the malicious archive. The vulnerability impacts the availability of systems running vulnerable GuardDog versions. The issue has been fixed in version 2.7.1.

References

Community reviews

Loading reviews…