Skip to main content
CVE-2026-22871VulnerabilityPublished

CVE-2026-22871: DataDog guarddog · Path Traversal

Affects DataDog guarddogSource CVE Database V5

0

Not known to be exploited · CVSS 8.7 High : upgrade to 2.7.1 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.7.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade DataDog guarddog to 2.7.1.

Affected software

ProductAffectedFixed in
DataDogguarddogAffected
  • <2.7.1
Fixed in
  • 2.7.1
PyPIguarddogpkg:pypi/guarddogOther threatsAffected
  • <2.7.1
Fixed in
  • 2.7.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediately upgrade GuardDog to version 2.7.1 or later to apply the official fix for the path traversal vulnerability. 2. Audit all systems running GuardDog to identify any usage of vulnerable versions and remove or isolate affected instances. 3. Implement strict monitoring and logging of package extraction activities, focusing on unexpected file writes outside designated directories. 4. Employ file integrity monitoring solutions to detect unauthorized changes to critical system files that could result from exploitation. 5. Restrict user permissions and execution contexts for GuardDog to minimize the impact of potential exploitation, such as running it in sandboxed or containerized environments. 6. Review and tighten supply chain security policies, including verifying package sources and hashes before extraction. 7. Educate developers and security teams about the risks of malicious PyPI packages and the importance of timely updates. 8. Consider network segmentation and endpoint detection and response (EDR) tools to detect and contain suspicious activities related to package analysis workflows.

Description

CVE-2026-22871 is a high-severity path traversal vulnerability in DataDog's GuardDog CLI tool versions prior to 2.7.1. The flaw exists in the safe_extract() function, allowing malicious PyPI packages to write files outside the intended extraction directory. This arbitrary file overwrite can lead to remote code execution without requiring authentication, though user interaction is needed to trigger the extraction. The vulnerability has a CVSS 4.0 score of 8.7, indicating a significant risk. GuardDog is used to identify malicious PyPI packages, so compromised environments could be exploited by attackers to execute arbitrary code. The issue is fixed in version 2.

References

Community reviews

Loading reviews…