CVE-2026-22901: QNAP Systems QuNetSwitch · OS Command Injection
Affects QNAP Systems QuNetSwitchSource CVE Database V5
Not known to be exploited · CVSS 6.3 Medium : upgrade to 2.0.5.0906 when convenient.
Data as of 1 Nov 2026, 11:02 UTC
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.5.0906
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 20 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade QNAP Systems QuNetSwitch to 2.0.5.0906.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| QNAP Systems Inc.QuNetSwitch | Affected
| Fixed in
|
AI-suggested
Organizations should immediately upgrade QuNetSwitch to version 2.0.5.0906 or later, where the vulnerability has been fixed. In addition to patching, organizations should enforce strong user account management policies, including multi-factor authentication (MFA) to reduce the risk of credential compromise. Network segmentation should be employed to limit access to QuNetSwitch management interfaces only to trusted administrators. Monitoring and logging of user activities on QuNetSwitch should be enhanced to detect suspicious command executions or unauthorized access attempts. If patching is temporarily not possible, applying strict access control lists (ACLs) and firewall rules to restrict network access to the affected systems can reduce exposure. Regularly auditing user accounts and removing inactive or unnecessary accounts will also reduce the attack surface. Finally, organizations should conduct security awareness training to prevent credential phishing or social engineering attacks that could lead to account compromise.
Description
A command injection vulnerability has been reported to affect QuNetSwitch. If a remote attacker gains a user account, they can then exploit the vulnerability to execute arbitrary commands. We have already fixed the vulnerability in the following version: QuNetSwitch 2.0.5.0906 and later