Skip to main content
CVE-2026-22922VulnerabilityPublished

CVE-2026-22922: Apache Airflow · Incorrect Use of Privileged APIs

Affects Apache AirflowSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.1.7 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Apache Airflow to 3.1.7.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache AirflowAffected
  • >=3.1.0 <3.1.7
Fixed in
  • 3.1.7

AI-suggested

The primary mitigation is to upgrade Apache Airflow installations to version 3.1.7 or later, where this authorization flaw is corrected. Organizations should implement a strict patch management process to ensure timely updates of workflow orchestration tools. Additionally, review and audit user permissions and roles within Airflow to enforce the principle of least privilege, ensuring users only have access necessary for their tasks. Implement monitoring and alerting on unusual access patterns to task logs, especially from users with limited permissions. Consider network segmentation and access controls to restrict Airflow UI and API access to trusted users and systems. If upgrading immediately is not feasible, temporarily restrict access to task logs or disable task log viewing features for users with custom limited permissions. Conduct regular security assessments and penetration testing focused on workflow management platforms to detect authorization weaknesses early.

Description

CVE-2026-22922 is an authorization vulnerability in Apache Airflow versions 3.1.0 through 3.1.6 that allows authenticated users with limited custom permissions to access task logs without proper authorization. This flaw arises from incorrect use of privileged APIs, classified under CWE-648. The vulnerability has a CVSS score of 6.5, indicating medium severity, with high impact on confidentiality but no impact on integrity or availability. Exploitation requires authentication but no user interaction, and the flaw is resolved in Apache Airflow 3.1.

References

Community reviews

Loading reviews…