Skip to main content
VulnerabilityPublished Updated

CVE-2026-23317: Linux kernel · drm/vmwgfx: Return the correct value in vmw_translate_ptr functions

Affects Linux kernelSource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High · fixed in ce3a5cf139787c186d5d54336107298cacaad2b9 : patch Linux kernel soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-10-16.

Patch
Available – fixed in ce3a5cf139787c186d5d54336107298cacaad2b9, 5023ca80f9589295cb60735016e39fc5cc714243, 531f45589787799aa81b63e1e1f8e71db5d93dd1 +4
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
LinuxLinuxAffected
  • >=6.1.7 <6.1.167
Fixed in
  • ce3a5cf139787c186d5d54336107298cacaad2b9
  • 5023ca80f9589295cb60735016e39fc5cc714243
  • 531f45589787799aa81b63e1e1f8e71db5d93dd1
  • 149f028772fa2879d9316b924ce948a6a0877e45
  • 36cb28b6d303a81e6ed4536017090e85e0143e42
  • 7e55d0788b362c93660b80cc5603031bbbdefa98
  • 6.1.167
LinuxLinuxAffected
  • =6.2
Fixed in–

AI-suggested

This vulnerability has been fixed in Linux kernel version 6.1.167 and later. Users and administrators should update affected Linux kernel versions to 6.1.167 or later to remediate this issue. No other mitigation is required as the fix is available.

Description

CVE-2026-23317 is a high-severity vulnerability in the Linux kernel's drm/vmwgfx component. The vmw_translate_ptr functions incorrectly returned success when a lookup failed due to improper error handling after a code change. This flaw could lead to uninitialized and out-of-bounds memory accesses.

References

Community reviews

Loading reviews…