Skip to main content
CVE-2026-23476VulnerabilityPublished

CVE-2026-23476: NeoRazorX facturascripts · Cross-site Scripting

Affects NeoRazorX facturascriptsSource CVE Database V5

0

Not known to be exploited · CVSS 5.4 Medium : upgrade to 2025.8 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2025.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade facturascripts and neorazorx/facturascripts to 2025.8.

Affected software

ProductAffectedFixed in
NeoRazorXfacturascriptsAffected
  • <2025.8
Fixed in
  • 2025.8
GitHubneorazorx/facturascriptspkg:github/neorazorx/facturascriptsOther threatsAffected
  • <2025.8
Fixed in
  • 2025.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade FacturaScripts to version 2025.8 or later, where the vulnerability is fixed. Until upgrade is possible, organizations should implement strict input validation and sanitization at the application and database layers to prevent injection of malicious input that triggers error messages. Web application firewalls (WAFs) can be configured to detect and block suspicious input patterns that may exploit this XSS flaw. Educate users to avoid interacting with suspicious links or inputs that could trigger error messages. Limit user privileges to the minimum necessary to reduce the risk of exploitation by low-privilege attackers. Regularly audit and monitor application logs for unusual error message patterns or signs of attempted exploitation. Finally, ensure secure coding practices are followed in customizations or plugins to avoid similar issues.

Description

CVE-2026-23476 is a reflected cross-site scripting (XSS) vulnerability in FacturaScripts, an open-source ERP and accounting software by NeoRazorX, affecting versions prior to 2025.8. The flaw arises from improper sanitization when displaying error messages triggered by database input errors, due to the use of Twig's | raw filter which bypasses HTML escaping. An attacker can exploit this by causing a database error with crafted input, leading to execution of malicious scripts in the victim's browser. The vulnerability requires low privileges but does require user interaction and results in partial confidentiality and integrity impact without affecting availability. It is rated medium severity with a CVSS score of 5.4 and has no known exploits in the wild. The issue is fixed in version 2025.8. European organizations using vulnerable versions of FacturaScripts, especially in finance and accounting roles, should prioritize patching to prevent potential targeted attacks.

References

Community reviews

Loading reviews…