Skip to main content
VulnerabilityPublished

CVE-2026-23480: blinkospace blinko · Authentication Bypass Using an Alternate Path or Channel

Affects blinkospace blinkoSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.8.4 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.8.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade blinko and blinkospace/blinko to 1.8.4.

Affected software

ProductAffectedFixed in
blinkospaceblinkoAffected
  • <1.8.4
Fixed in
  • 1.8.4
GitHubblinkospace/blinkopkg:github/blinkospace/blinkoOther threatsAffected
  • <1.8.4
Fixed in
  • 1.8.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade Blinko to version 1.8.4 or later, where the vulnerability is patched. Until upgrading is possible, restrict access to the upsertUser endpoint by implementing additional access controls such as network segmentation, API gateway policies, or firewall rules limiting access to trusted users only. Conduct thorough audits of user accounts and password changes to detect unauthorized modifications. Implement multi-factor authentication (MFA) to reduce the risk of compromised credentials being used to exploit this vulnerability. Review and harden authentication and authorization logic in custom integrations or extensions of Blinko. Monitor logs for unusual activity related to user management endpoints. Educate users about the importance of safeguarding credentials to prevent exploitation by insiders or attackers with stolen accounts. Finally, maintain an incident response plan to quickly address any detected exploitation attempts.

Description

Blinko is an AI-powered card note-taking project. Prior to version 1.8.4, there is a privilege escalation vulnerability. The upsertUser endpoint has 3 issues: it is missing superAdminAuthMiddleware, any logged-in user can call it; the originalPassword is an optional parameter and if not provided password verification is skipped; there is no check for input.id === ctx.id (ownership verification). This could result in any authenticated user modifying other users' passwords, direct escalation to superadmin, and complete account takeover. This issue has been patched in version 1.8.4.

References

Community reviews

Loading reviews…