CVE-2026-23535: WeblateOrg wlc · Path Traversal
Affects WeblateOrg wlcSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 1.17.2 soon.
Data as of 26 Oct 2026, 12:55 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.17.2
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade wlc and weblateorg/wlc to 1.17.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| WeblateOrgwlc | Affected
| Fixed in
|
GitHubweblateorg/wlcpkg:github/weblateorg/wlcOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately upgrade all instances of wlc to version 1.17.2 or later to remediate the vulnerability. Additionally, organizations should audit and restrict access to Weblate servers, ensuring only trusted servers are used by clients. Implement network segmentation and firewall rules to limit client connections to authorized Weblate endpoints. Employ monitoring and alerting on unusual file system changes on machines running wlc, particularly in directories used for translation downloads. Incorporate integrity checks and digital signatures for translation files to detect unauthorized modifications. Educate users about the risks of connecting to untrusted Weblate servers and enforce strict policies on client-server trust relationships. Finally, review and update incident response plans to address potential exploitation scenarios involving arbitrary file writes.
Description
CVE-2026-23535 is a high-severity path traversal vulnerability in the Weblate command-line client (wlc) versions prior to 1.17.2. It allows a malicious Weblate server to instruct the client to write files to arbitrary locations on the user's filesystem during multi-translation downloads. Exploitation requires network access to a malicious or compromised Weblate server and user interaction to trigger the download. The vulnerability impacts confidentiality, integrity, and availability by enabling unauthorized file writes, potentially leading to code execution or system compromise. The issue is fixed in wlc version 1.17.2. European organizations using vulnerable wlc versions should upgrade promptly and validate server trustworthiness.
References
- github.com/WeblateOrg/wlc/security/advisories/GHSA-mmwx-79f6-67jg (opens in a new tab)
- github.com/WeblateOrg/wlc/pull/1128 (opens in a new tab)
- github.com/WeblateOrg/wlc/commit/216e691c6e50abae97fe2e4e4f21501bf49a585f (opens in a new tab)
- github.com/WeblateOrg/wlc/releases/tag/1.17.2 (opens in a new tab)