Skip to main content
VulnerabilityPublished

CVE-2026-23552: Apache Camel · Origin Validation Error

Affects Apache CamelSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 4.18.0 as a priority.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.18.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache to 4.18.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache CamelAffected
  • >=4.15.0 <4.18.0
Fixed in
  • 4.18.0
MavenApache Software Foundation/org.apache.camel:camel-keycloakpkg:maven/Apache Software Foundation/org.apache.camel:camel-keycloakOther threatsAffected
  • >=4.15.0 <4.18.0
Fixed in
  • 4.18.0
Mavenorg.apache.camel/camel-corepkg:maven/org.apache.camel/camel-coreOther threatsAffected
  • =4.15.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-23552, organizations should immediately upgrade Apache Camel to version 4.18.0 or later, where the issuer validation flaw has been corrected. Until upgrading is possible, administrators should review and restrict access to Keycloak tokens, ensuring tokens are only accepted from trusted realms. Implement additional validation layers in the application logic to verify the 'iss' claim manually if feasible. Employ strict network segmentation and access controls to limit token exposure and reduce the risk of token theft or misuse. Monitor authentication logs for anomalies indicating cross-realm token usage. Conduct thorough security assessments of multi-tenant configurations to ensure tenant boundaries are enforced. Educate development and operations teams about the importance of validating JWT claims and the risks of origin validation errors. Consider deploying runtime application self-protection (RASP) or Web Application Firewalls (WAFs) with custom rules to detect and block suspicious token usage patterns. Finally, maintain up-to-date inventory of affected systems and integrate vulnerability scanning to detect outdated Apache Camel versions.

Description

Cross-Realm Token Acceptance Bypass in KeycloakSecurityPolicy Apache Camel Keycloak component. The Camel-Keycloak KeycloakSecurityPolicy does not validate the iss (issuer) claim of JWT tokens against the configured realm. A token issued by one Keycloak realm is silently accepted by a policy configured for a completely different realm, breaking tenant isolation. This issue affects Apache Camel: from 4.15.0 before 4.18.0. Users are recommended to upgrade to version 4.18.0, which fixes the issue.

References

Community reviews

Loading reviews…