CVE-2026-2360: DALIBO PostgreSQL Anonymizer · Uncontrolled Search Path Element
Affects DALIBO PostgreSQL AnonymizerSource CVE Database V5
Not known to be exploited · CVSS 8.0 High : upgrade to 3.0.1 soon.
Data as of 26 Oct 2026, 11:07 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.0.1
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 11 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade DALIBO PostgreSQL Anonymizer to 3.0.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DALIBOPostgreSQL Anonymizer | Affected
| Fixed in
|
AI-suggested
European organizations should immediately upgrade the PostgreSQL Anonymizer extension to version 3.0.1 or later to remediate this vulnerability. Review and harden schema permissions by ensuring that the public schema does not grant CREATE privileges to non-superusers, especially on PostgreSQL 14 or upgraded instances. Avoid adding custom schemas with CREATE privileges for untrusted users in the search_path. Implement strict role-based access controls limiting who can create operators or extensions. Regularly audit database roles and permissions to detect misconfigurations. Employ monitoring and alerting for unusual extension creation or operator definition activities. Consider isolating critical databases and applying network segmentation to limit exposure. Finally, maintain up-to-date backups and test recovery procedures to mitigate potential data loss from exploitation.
Description
PostgreSQL Anonymizer contains a vulnerability that allows a user to gain superuser privileges by creating a custom operator in the public schema and place malicious code in that operator. This operator will later be executed with superuser privileges when the extension is created. The risk is higher with PostgreSQL 14 or with instances upgraded from PostgreSQL 14 or a prior version. With PostgreSQL 15 and later, the creation permission on the public schema is revoked by default and this exploit can only be achieved if a superuser adds a new schema in her/his own search_path and grants the CREATE privilege on that schema to untrusted users, both actions being clearly discouraged by the PostgreSQL documentation. The problem is resolved in PostgreSQL Anonymizer 3.0.1 and further versions