Skip to main content
CVE-2026-2361VulnerabilityPublished

CVE-2026-2361: DALIBO PostgreSQL Anonymizer · Uncontrolled Search Path Element

Affects DALIBO PostgreSQL AnonymizerSource CVE Database V5

0

Not known to be exploited · CVSS 8.0 High : upgrade to 3.0.1 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
8.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.1
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade DALIBO PostgreSQL Anonymizer to 3.0.1.

Affected software

ProductAffectedFixed in
DALIBOPostgreSQL AnonymizerAffected
  • >=1 <3.0.1
Fixed in
  • 3.0.1

AI-suggested

European organizations should immediately upgrade DALIBO PostgreSQL Anonymizer to version 3.0.1 or later to remediate this vulnerability. Additionally, review and restrict CREATE privileges, especially on the public schema, limiting them to trusted users only. Implement strict role-based access controls (RBAC) and audit database permissions regularly to detect and prevent unauthorized privilege escalations. Disable or restrict the use of the anon.get_tablesample_ratio function if not essential. Employ database activity monitoring to detect anomalous function calls or creation of suspicious views. Finally, ensure PostgreSQL instances are updated to the latest supported versions and apply all relevant security patches promptly. Conduct security awareness training for DBAs and developers about the risks of granting excessive privileges.

Description

PostgreSQL Anonymizer contains a vulnerability that allows a user to gain superuser privileges by creating a temporary view based on a function containing malicious code. When the anon.get_tablesample_ratio function is then called, the malicious code is executed with superuser privileges. This privilege elevation can be exploited by users having the CREATE privilege in PostgreSQL 15 and later. The risk is higher with PostgreSQL 14 or with instances upgraded from PostgreSQL 14 or a prior version because the creation permission on the public schema is granted by default. The problem is resolved in PostgreSQL Anonymizer 3.0.1 and further versions

References

Community reviews

Loading reviews…