Skip to main content
VulnerabilityPublished

CVE-2026-23794: Apache Syncope · Cross-site Scripting

Affects Apache SyncopeSource CVE Database V5

0

Not known to be exploited · CVSS 6.8 Medium · fixed in 3.0.16 : update Apache Syncope when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.16
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache SyncopeAffected
  • >=3.0 <=3.0.15
  • >=4.0 <=4.0.3
Fixed in–
Mavenorg.apache.syncope/syncopepkg:maven/org.apache.syncope/syncopeOther threatsAffected
  • =3.0
  • =4.0
Fixed in–
MavenApache Software Foundation/org.apache.syncope.client.idrepo:syncope-client-idrepo-common-uipkg:maven/Apache Software Foundation/org.apache.syncope.client.idrepo:syncope-client-idrepo-common-uiOther threatsAffected
  • >=3.0 <=3.0.15
  • >=4.0 <=4.0.3
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade Apache Syncope installations to versions 3.0.16 or 4.0.4, which contain the official patches for this vulnerability. In addition to patching, organizations should implement strict Content Security Policies (CSP) to restrict the execution of unauthorized scripts in browsers. Web Application Firewalls (WAFs) can be configured to detect and block suspicious input patterns indicative of reflected XSS attempts targeting the login page. User awareness training should emphasize the risks of clicking on unsolicited or suspicious links, especially those purporting to lead to login portals. Logging and monitoring should be enhanced to detect anomalous login attempts or unusual URL parameters. For environments where immediate patching is not feasible, consider restricting access to the Syncope Enduser portal via VPN or IP whitelisting to reduce exposure. Regular security assessments and penetration tests should include checks for XSS vulnerabilities in critical web applications.

Description

Reflected XSS in Apache Syncope's Enduser Login page. An attacker that tricks a legitimate user into clicking a malicious link and logging in to Syncope Enduser could steal that user's credentials. This issue affects Apache Syncope: from 3.0 through 3.0.15, from 4.0 through 4.0.3. Users are recommended to upgrade to version 3.0.16 / 4.0.4, which fix this issue.

References

Community reviews

Loading reviews…