CVE-2026-23846: Quenary tugtainer · Use of GET Request Method With Sensitive Query Strings
Affects Quenary tugtainerSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 1.16.1 soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.16.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 19 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade tugtainer and quenary/tugtainer to 1.16.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Quenarytugtainer | Affected
| Fixed in
|
GitHubquenary/tugtainerpkg:github/quenary/tugtainerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
1. Immediately upgrade tugtainer installations to version 1.16.1 or later, where the vulnerability is patched by moving password transmission to the HTTP request body. 2. Conduct a thorough audit of server access logs, proxy logs, and browser histories to identify any exposed passwords and rotate affected credentials promptly. 3. Restrict access to logs and ensure that logging configurations do not capture sensitive query parameters. 4. Implement network segmentation and access controls to limit exposure of management interfaces and logs to trusted personnel only. 5. Educate users and administrators about the risks of transmitting sensitive data in URLs and encourage secure authentication practices. 6. Monitor network traffic for suspicious activity that could indicate exploitation attempts. 7. Where possible, enforce use of HTTPS to protect query strings in transit, although this does not prevent logging exposure. 8. Integrate security scanning tools to detect insecure use of GET requests with sensitive data in custom or third-party applications.
Description
CVE-2026-23846 is a high-severity vulnerability in Quenary's tugtainer versions prior to 1.16.1, where password authentication uses HTTP GET requests with sensitive query strings. This insecure design causes passwords to be exposed in server logs, browser history, Referer headers, and proxy logs, risking credential leakage. The vulnerability does not require authentication but does require user interaction, and it affects the confidentiality and integrity of credentials without impacting availability. The issue is patched in version 1.16.1. European organizations using tugtainer for Docker container automation should urgently update to mitigate exposure risks. Countries with significant container adoption and cloud infrastructure usage, such as Germany, France, and the Netherlands, are most likely to be affected.