CVE-2026-23947: orval · Command Injection
Affects orvalSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 9.3 Critical : upgrade to 8.0.2 or 7.19.0 as a priority.
Data as of 25 Oct 2026, 18:53 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.0.2, 7.19.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade orval to 8.0.2 or 7.19.0; orval-labs/orval to 7.19.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| orval-labsorval | Affected
| Fixed in
|
npmorval-labs/orvalpkg:npm/orval-labs/orvalOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
1. Immediately upgrade orval to version 7.19.0 or 8.0.2 or later, where the vulnerability is fixed. 2. Implement strict validation and sanitization of all OpenAPI specifications before feeding them into orval, especially those obtained from external or untrusted sources. 3. Establish a policy to only consume OpenAPI specs from trusted and verified providers. 4. Use static code analysis tools to scan generated client code for suspicious or injected code patterns. 5. Integrate security checks into CI/CD pipelines to detect unsafe OpenAPI specs or vulnerable orval versions. 6. Isolate environments where generated clients run to limit the blast radius of potential code execution. 7. Monitor runtime environments for anomalous behavior indicative of exploitation attempts. 8. Educate development teams about the risks of consuming untrusted API specifications and secure coding practices related to code generation tools.
Description
CVE-2026-23947 is a critical command injection vulnerability in orval, a tool generating type-safe TypeScript clients from OpenAPI/Swagger specs. Versions prior to 7.19.0 and between 8.0.0-rc.0 and 8.0.2 are affected. The flaw allows untrusted OpenAPI specifications to inject arbitrary JavaScript/TypeScript code via the x-enumDescriptions field, which is embedded without proper escaping during enum generation.