Skip to main content
VulnerabilityPublished

CVE-2026-23980: Apache Superset · SQL Injection

Affects Apache SupersetSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 6.0.0 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache Superset and apache-superset to 6.0.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache SupersetAffected
  • <6.0.0
Fixed in
  • 6.0.0
PyPIapache-supersetpkg:pypi/apache-supersetOther threatsAffected
  • <6.0.0
Fixed in
  • 6.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-23980, organizations should immediately upgrade Apache Superset to version 6.0.0 or later, where the vulnerability is patched. Until the upgrade can be performed, restrict read access to trusted users only and monitor database query logs for unusual or suspicious SQL patterns indicative of injection attempts. Implement strict input validation and sanitization on any custom extensions or integrations that interact with the sqlExpression or where parameters. Employ web application firewalls (WAFs) with SQL injection detection rules tailored to Superset’s query patterns. Conduct regular security audits and penetration testing focused on injection vulnerabilities in analytics platforms. Additionally, enforce the principle of least privilege by limiting database user permissions associated with Superset to minimize potential data exposure. Maintain up-to-date backups and ensure incident response plans include scenarios involving data leakage through injection attacks.

Description

Improper Neutralization of Special Elements used in a SQL Command ('SQL Injection') vulnerability in Apache Superset allows an authenticated user with read access to conduct error-based SQL injection via the sqlExpression or where parameters. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

References

Community reviews

Loading reviews…