Skip to main content
VulnerabilityPublished

CVE-2026-23983: Apache Superset · Information Exposure

Affects Apache SupersetSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.3 Low : upgrade to 6.0.0 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.0.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache Superset and apache-superset to 6.0.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache SupersetAffected
  • <6.0.0
Fixed in
  • 6.0.0
PyPIapache-supersetpkg:pypi/apache-supersetOther threatsAffected
  • <6.0.0
Fixed in
  • 6.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate this vulnerability, organizations should upgrade Apache Superset to version 6.0.0 or later, where the issue is fixed. If upgrading is not immediately feasible, ensure the TAGGING_SYSTEM configuration is set to False, which disables the vulnerable Tag endpoint by default and prevents exposure. Review user roles and permissions to limit access to the Gamma role or other low-privilege accounts, minimizing the number of users who can exploit this flaw. Conduct audits of API usage and monitor for unusual access patterns to the Tag endpoint if enabled. Additionally, consider implementing network-level access controls to restrict access to the Superset instance and enforce strong authentication mechanisms. Regularly update and patch Apache Superset installations as part of standard security hygiene to prevent exploitation of known vulnerabilities.

Description

A Sensitive Data Exposure vulnerability exists in Apache Superset allowing authenticated users to retrieve sensitive user information. The Tag endpoint (disabled by default) allows users to retrieve a list of objects associated with a specific tag. When these associated objects include Users, the API response improperly serializes and returns sensitive fields, including password hashes (pbkdf2), email addresses, and login statistics. This vulnerability allows authenticated users with low privileges (e.g., Gamma role) to view sensitive authentication data This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue or make sure TAGGING_SYSTEM is False (Apache Superset current default)

References

Community reviews

Loading reviews…