Skip to main content
VulnerabilityPublished

CVE-2026-23990: controlplaneio-fluxcd flux-operator · Improper Privilege Management

Affects controlplaneio-fluxcd flux-operatorSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.40.0 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.40.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade flux-operator and controlplaneio-fluxcd/flux-operator to 0.40.0.

Affected software

ProductAffectedFixed in
controlplaneio-fluxcdflux-operatorAffected
  • >=0.36.0 <0.40.0
Fixed in
  • 0.40.0
GitHubcontrolplaneio-fluxcd/flux-operatorpkg:github/controlplaneio-fluxcd/flux-operatorOther threatsAffected
  • >=0.36.0 <0.40.0
Fixed in
  • 0.40.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately audit their Kubernetes clusters to identify Flux Operator versions in use and upgrade to version 0.40.0 or later, where the vulnerability is patched. Administrators must review OIDC provider configurations to ensure tokens include all expected claims such as 'email' and 'groups'. Avoid using custom CEL expressions that can evaluate to empty values for username or groups. Implement strict validation of token claims before processing to prevent empty impersonation fields. Additionally, restrict access to the Flux Operator Web UI to trusted users only, and monitor API request logs for anomalous behavior indicative of privilege escalation attempts. Employ Kubernetes audit logging and alerting on service account privilege usage anomalies. Consider implementing network segmentation and zero-trust principles to limit the potential blast radius of compromised operator credentials. Regularly review and tighten RBAC policies associated with the flux-operator service account to minimize privileges to the least necessary.

Description

CVE-2026-23990 is a medium-severity privilege escalation vulnerability in the Flux Operator versions 0.36.0 to before 0.40.0. It arises from improper privilege management in the Web UI authentication code when configured with certain OIDC providers issuing tokens missing expected claims or with custom CEL expressions that yield empty username and groups values. This causes Kubernetes client-go to omit impersonation headers, resulting in API requests executing with the operator's service account privileges rather than the limited authenticated user permissions. Exploitation can lead to privilege escalation and data exposure within Kubernetes clusters using the affected Flux Operator versions. The vulnerability is patched in version 0.40.

References

Community reviews

Loading reviews…