Skip to main content
CVE-2026-24037VulnerabilityPublished

CVE-2026-24037: horilla · Cross-site Scripting

Affects horillaSource CVE Database V5

0

Not known to be exploited · CVSS 4.8 Medium : upgrade to 1.5.0 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.5.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade horilla and horilla-opensource/horilla to 1.5.0.

Affected software

ProductAffectedFixed in
horilla-opensourcehorillaAffected
  • >=1.4.0 <1.5.0
Fixed in
  • 1.5.0
GitHubhorilla-opensource/horillapkg:github/horilla-opensource/horillaOther threatsAffected
  • <1.5.0 >=1.4.0
Fixed in
  • 1.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade Horilla installations to version 1.5.0 or later, where the vulnerability has been fixed. Organizations should audit their HRMS deployments to identify any instances running vulnerable versions. In addition to patching, implement strict input validation and sanitization tailored to the context of input usage rather than relying solely on regex-based filters. Deploy Content Security Policies (CSP) to restrict the execution of unauthorized scripts and reduce the impact of potential XSS attacks. Employ multi-factor authentication and strict access controls to limit the risk posed by compromised privileged accounts. Conduct security awareness training to reduce the likelihood of successful social engineering or phishing attempts that could trigger user interaction exploitation. Regularly monitor logs and web traffic for suspicious activities indicative of attempted XSS or CSRF attacks. Finally, consider using web application firewalls (WAFs) with updated signatures to detect and block malicious payloads targeting this vulnerability.

Description

CVE-2026-24037 is a medium-severity cross-site scripting (XSS) vulnerability in Horilla, an open-source Human Resource Management System (HRMS), affecting versions 1.4.0 up to but not including 1.5.0. The vulnerability arises from an incomplete and context-agnostic input filtering mechanism in the has_xss() function, which fails to properly neutralize malicious input. Exploitation allows attackers to execute arbitrary JavaScript, redirect users to malicious domains, and steal CSRF tokens, enabling further attacks against administrative users. The issue requires high privileges and user interaction but does not impact availability. The vulnerability has been fixed in version 1.5.

References

Community reviews

Loading reviews…