CVE-2026-24098: Apache Airflow · Information Exposure
Affects Apache AirflowSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.1.7 when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 9 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Apache Airflow to 3.1.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Airflow | Affected
| Fixed in
|
AI-suggested
To mitigate CVE-2026-24098, organizations should promptly upgrade Apache Airflow to version 3.1.7 or later, where the vulnerability has been fixed. Beyond patching, administrators should review and enforce strict role-based access controls (RBAC) to limit user permissions to only those DAGs necessary for their role, minimizing the number of users who can access any DAGs. Monitoring and logging access to DAGs and error messages should be enhanced to detect anomalous or unauthorized access attempts. Consider implementing network segmentation and multi-factor authentication (MFA) for Airflow access to reduce the risk of compromised credentials being used to exploit this vulnerability. Additionally, review Airflow configurations to ensure error messages and logs do not expose sensitive information unnecessarily. Regular security assessments and audits of Airflow deployments can help identify and remediate similar information disclosure issues proactively.
Description
CVE-2026-24098 is a medium severity vulnerability in Apache Airflow versions 3.0.0 through 3.1.7 that allows authenticated users with access to specific DAGs to view import errors from other DAGs they are not authorized to access. This exposure of sensitive information could reveal internal system details or configuration errors, potentially aiding attackers in further exploitation. The vulnerability requires authenticated access but no user interaction beyond login. It impacts confidentiality but not integrity or availability. Organizations using affected Airflow versions should upgrade to 3.1.