Skip to main content
VulnerabilityPublished

CVE-2026-24132: orval · Command Injection

Affects orvalSource CVE Database V5

0

Not known to be exploited · CVSS 7.7 High : upgrade to 8.0.3 or 7.20.0 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.0.3, 7.20.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade orval and orval-labs/orval to 8.0.3 or 7.20.0.

Affected software

ProductAffectedFixed in
orval-labsorvalAffected
  • >=8.0.0-rc.0 <8.0.3
Fixed in
  • 8.0.3
orval-labsorvalAffected
  • <7.20.0
Fixed in
  • 7.20.0
npmorval-labs/orvalpkg:npm/orval-labs/orvalOther threatsAffected
  • <7.20.0
  • >=8.0.0 <8.0.3
Fixed in
  • 7.20.0
  • 8.0.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Upgrade orval to version 7.20.0 or later, or 8.0.3 or later, where the vulnerability is fixed.
  2. Implement strict validation and sanitization of all OpenAPI specifications before processing, especially those obtained from untrusted or external sources.
  3. Employ static code analysis and security scanning on generated client and mock files to detect injected malicious code early in the development cycle.
  4. Restrict usage of orval to trusted internal specifications where possible, minimizing exposure to crafted malicious inputs.
  5. Integrate security gates in CI/CD pipelines to verify the integrity of generated code artifacts.
  6. Educate developers and DevOps teams about the risks of processing untrusted API specifications and encourage secure coding practices.
  7. 8. Consider isolating the code generation environment to limit potential impact of malicious code execution.

Description

Orval generates type-safe JS clients (TypeScript) from any valid OpenAPI v3 or Swagger v2 specification. Versions 7.19.0 and below and 8.0.0-rc.0 through 8.0.2 allow untrusted OpenAPI specifications to inject arbitrary TypeScript/JavaScript into generated mock files via the const keyword on schema properties. These const values are interpolated into the mock scalar generator (getMockScalar in packages/mock/src/faker/getters/scalar.ts) without proper escaping or type-safe serialization, which results in attacker-controlled code being emitted into both interface definitions and faker/MSW handlers. The vulnerability is similar in impact to the previously reported enum x-enumDescriptions (GHSA-h526-wf6g-67jv), but it affects a different code path in the faker-based mock generator rather than @orval/core. The issue has been fixed in versions 7.20.0 and 8.0.3.

References

Community reviews

Loading reviews…